AFCA Forums Home
Home Search search Menu menu Not logged in - Login | Register

 Moderated by: Steve Cunningham, Stan Adams, Rod Rogers
New Topic Reply Printer Friendly
GE Fan  Rate Topic 
AuthorPost
 Posted: Wed Dec 29th, 2021 02:49 pm
  PMQuoteReply
1st Post
Steven P Dempsey
Guest


Joined: Tue May 15th, 2012
Location: Clarksville, Virginia USA
Status: 
Offline
This blade, which came with the fan, does not fit - (from a BMY, star or Brass Bell?) TYPE AOU FORM AE1 16" - - That is an R&M blade on the fan, for testing purposes.Any reason that blade won't work? Pitch seems the same.






Back To Top PMQuoteReply  

 Posted: Fri Dec 31st, 2021 03:34 am
  PMQuoteReply
2nd Post
John Nyman
AFCA Member


Joined: Sat Aug 26th, 2017
Location: Elkton, Va, USA
Status: 
Offline
I did this once and the wrong blade caused the motor to draw more current than was appropriate...even though it looked like a good match. FWIW

Back To Top PMQuoteReply

 Posted: Tue Jan 18th, 2022 11:29 am
  PMQuoteReply
3rd Post
Kim Frank
AFCA Member


Joined: Tue Nov 15th, 2005
Location: Whitestown, USA
Status: 
Offline
With the longer hub, it might go to a GE Kidney. They used blades with a longer hub. The front hole is plugged on Kidneys too.

Back To Top PMQuoteReply  

Current time is 06:16 am  
AFCA Forums > Antique Fan Collectors Association > Pre-1950 (Antique) > GE Fan Top



Beige Theme By: Di @ UltraBB
UltraBB 1.17 Copyright © 2007-2008 Data 1 Systems
Page processed in 0.0742 seconds (28% database + 72% PHP). 26 queries executed.